× Loading
Saleen Software Solutions
     Our Lord is coming back in X days Y hours Z minutes and V seconds. Are you prepared?
We stand with Israel!
    Professional software development
 
|
|
|
Login / Register
Check all your programs
for updates.





   Saleen Software  >  Forums  >  Web Downloader  > 
0
Webdownloader won't start, Unwaders.A!ml
Bug report Bug report
Open
Post a reply / Write a message here

1 2 previous next
1.png saleen support
2019-10-12 11:37:18⁼

Thank you for the update and the good news my friend. 

Also thanks for the kind words. 

Have a great weekend. 

👍 1
999979.png Big Joe Nobody
2019-10-12 10:47:41⁼

Hi there saleen support!

Just an update, hopefully good news.

Yesterday I checked for updates & got another Security intelligence update after which Webdownloader returned to working again.

I waited before coming back because previously it had started working right after the morning update but then stopped again & I did not want to jinx it. :)

Even got a further Security intelligence update in the evening but Webdownloader remained unblocked & continued to work normally.

That makes three Security intelligence updates yesterday, feels like maybe they were working something through.

I've never had Defender on Windows 10 block anything like this before, one of the things I like about it is how low profile & unobtrusive it normally is.

Thanks for responding & help in this matter, also thanks for such a great tool as Webdownloader!

999979.png Big Joe Nobody
2019-10-11 13:48:31⁼

Hi there saleen support!

Okay, thank-you for getting back so quick!

I'm at a loss then, I'll report back if I come up with anything regarding this.

1.png saleen support
2019-10-11 13:36:35⁼

Hi again.

I am confirming that I am using the unregistered version (with ads),

with no issues.

999979.png Big Joe Nobody
2019-10-11 13:13:14⁼

Hi there saleen support!

So strange, I was literally using Webdownloader the day before without any problems, only since KB2267602 Version 1.303.1350.0 has this happened.

Seeing that you can't reproduce the problem, I uninstalled Webdownloader then re-installed the latest download to see if that might help.

Same problem, Webdownloader will not run & Defender logs that it was blocked due to threat.

Scans come up clean, including Defender Offline scan & Defender scans of the Webdownloader exe.

I do note that the detected threat is one related to serving unwanted adverts in browsers.

I have not been seeing this issue in any browser I use.

It did make me wonder though, Webdownloader does display adds in the locked version does it not?

Is it possible that it is this feature that Window's Defender is now detecting as a threat when the program tries to run?

If so, is it possible that anyone with an unlocked version are not seeing the issue?

I assume that you, as Saleen Support, would be using an unlocked version of Webdownloader with adverts disabled?

If so, is it possible for you to check with the adverts enabled to see if the program will still start?

Sorry for any inconvenience & thank-you kindly for your help!

1.png saleen support
2019-10-11 12:11:03⁼

Thanks for the details.

For the record, I just updated the Defender definitions and the program starts without complaining.

I am also on Windows 10 x64.

I just rescaned the executable through virustotal and it is completely clean.

https://www.virustotal.com/gui/file-analysis/MDBiNzQwOTZjNzdlYjViY2I0YWM1M2Y1MDIyN2NlZDQ6MTU3MDc5NjY4OA==/detection

I will keep an eye on it.


999979.png Big Joe Nobody
2019-10-11 10:51:27⁼

Hi there saleen support!

Sadly back to being blocked, same message as before warning of "Program:Win32/Unwaders.A!ml".

Windows won't let Webdownloader open.

Worked a couple of times this morning after the new Defender update but no more.

In Defender there is the option to "Allow on device" but I'm hesitant until more feedback on this.

Is anyone else seeing this behavior?

1.png saleen support
2019-10-11 10:19:21⁼

Thank you Big Joe for the update. 

999979.png Big Joe Nobody
2019-10-11 08:08:25⁼

Hi there saleen support!

This morning I checked for Windows updates to see if there was a new Security intelligence update for Windows Defender & there was:

KB2267602 Version 1.303.1437.0

After downloading & installing that I then tried to see if Webdownloader was still blocked from opening.

It opened & ran normally this time!

So I'm guessing the Security intelligence update I got yesterday made the false positive & today's corrected it?

I checked to see what yesterday's update was, the one I assume caused the blocking of Webdownloader, & it was:

KB2267602 Version 1.303.1350.0

Would be interesting to know if others experienced this issue after Version 1.303.1350.0 or not.

Of course if you did not install the security update yesterday you'd get the newer one & probably miss out on the problem.

Hope this is of use!

999979.png Big Joe Nobody
2019-10-10 14:43:41⁼

Hi there saleen support!

Thank-you for quick attention!

I just ran a custom scan of the whole folder "Saleen WebDownloader" with Windows Defender & it shows 0 threats.

Only when I try to run the WebDownloader.exe that there's a problem.

It does not start, blocked by Defender & eventually the mentioned notice comes up of threat.

1 2 previous next
  Copyright (c) 2007-2019 Saleen Software       2019-12-12 09:38:16