× Loading
Saleen Software Solutions
     Our Lord is coming back in X days Y hours Z minutes and V seconds. Are you prepared?
We stand with Israel!
    Professional software development
 
|
|
|
Login / Register
Check all your programs
for updates.





   Saleen Software  >  Forums  >  Video Manager  > 
0
Damaged database file? Please help!
Support Request Support Request
Open
Post a reply / Write a message here

502864.png Carl
2014-09-04 14:08:46⁼
Thanks!

Converting the database with build147 was successful, I'm able to run build123 again now.

I tested with 5 files and the internal frame generation works.

Looking forward to future updates you may have on the subject, but I'm good for now, so thanks again for this great support!
1.png saleen support
2014-08-30 11:39:45⁼
This is the email I sent.

Please install and run build 147
http://www.saleensoftware.com/VideoManager_build147_setup.zip
 
After it starts it will make the database compatible with the previous stable version.
Then it will close it self.
So build 147 does not run by it self.
It only allows you to install a previous build that was not compatible with the new database.
 
Please let me know if it works,
501038.png Carl
2014-08-29 16:25:13⁼
Hi, actually, I did not! I just checked again. Would you mind resending your email? Thanks!
1.png saleen support
2014-08-11 06:42:08⁼
Hi, did you get my email a few weeks ago?

488041.png Carl
2014-07-07 10:10:54⁼
Hi, thanks for your reply!

On #1: I see, that explains it. However, I actually did like the embedded version of "edit details", as the tab does not "get into the way" as the window can do.

On #2: Understood, frame generation is externally now, allowing frame processing in the background, good idea! But please see #5.

On #3: What I'm trying to say is, in the tag window there is "Assigned tags" on the left hand side, that's still there, and below "New tag" on the right hand side, a list of all tags ever used in the past. That list was useful to just pick a tag that was previously used on a different video, and assign it also to the current video. Now, that saved tag list is empty (Videomanager appears to have forgotten which tags were used in the past, hence my concern I might have damaged the database file somehow). In the meantime, I have added some tags to videos, and those newly used ones are being remembered, but my older ones are still not showing up in the list of saved tags. Hope that clarifies.

#4: One more observation: In the new version (build 146, compared to build123), there is a gap of approx. 150 pixel in left-right direction between the tabs (in particular: between the left border of "Favorites") and the right border of the former video player/now frame player, which can't be moved/removed/closed. Approximately where the former "Frames" tab image was, as still shown on your homepage on the Video Manager screenshot, on http://www.saleensoftware.com/VideoManager. In the space where the upper part of the artists head is shown in the screenshot on your homepage.

#5: Now, I'd like to come back to my original/main problem: With build123 (the one I used previously, which I reinstalled for test purposes in a different folder), I was able to generate frames for a .wmv (VC1) file using DX with no problems. With build146, using the same video file, frame generation produces all identical frames! I just tried that for the exact same video file. I'm using the latest version of K-Lite Codec Pack. Were there any changes from build123 (with the internal frame generation) to build146 (with external frame generation) that could explain that? I'd also be ok going back to build123, but it appears as if once the database file was used with build146, the older build123 can't work with the database anymore? Unfortunately, using VLC mode instead is not a viable solution, as VLC has video frame generation problems (regardless for build), typically 3-5 frames are ok, and the rest of the frames is all the same.

Thanks!
1.png saleen support
2014-06-30 03:30:34⁼
Hi and sorry for the delay to reply.

Previous versions of VideoManager were using an internal frame generation process that could bring down the entire application if something went wrong during playback or frame generation.

Latest version uses an external process to play videos and generate frames. So this answers your point #2

point #1: also my fault. Now you need to right click and select "edit details". Then a popup will appear. Once the popup is open you can select another video and it will refresh. No need to right click all the time. Let me know if you still prefer the embedded mode.

point #3: Need some clarification here. You mean the tags for your videos are missing?

485957.png Carl
2014-06-26 15:20:25⁼
Hi,
I'm afraid I may have screed up my database file, maybe by accidently running an older version of Videomanager. I suddenly had problems with frame capturing using the current version of Videomanager (DX crashed and VLC produced "all the same" thumbnails, I assume a video positioning problem). In order to find out if I changed something in my installed codecs or if Videomanager had a problem, I started an older version of Videomanager to see if the DX crashing also happens there. I think (but don't remember for sure) that it didn't even start properly or reported some error. Anyway, that did not solve the codec problem. However, after returning to the current version of Videomanager, it appears as if I have somehow damaged my database file, as now the current version of Videomanager behaves all strangely:
- The Video Details Tab has disappeared
- The player window in upper lefthand corner does not "play" anymore, only show thumbnails. If play is clicked, an external VLC window opens (same for DX).
- The Saved tags lists in now empty.
What's even more strange, even if I temporarily move the .ini and database files to a different folder (so that Videomanager doesn't find them and creates new ones), the Video Details Tab does not reappear and I continue to have the problem, that both VLC and DX video playback open in a separate windows.
Is the problem somewhere else?
What did I do? Can it be undone? Can I recover my tags and ratings info from the (damaged?) database? Also without having to re-generate all frames (Generate videostrips (frames) wants to rerenerate frames for files that already have frames, altough after clicking on such files once the lower screen "select video" tab shows the frames)?
I realize that this is more likely a user caused problem and not a software bug, but I'd very much appreciate any suggestions on how to best proceed!
Note: I used the manual install with drag and drop of the .exe file.
Many Thanks!
Carl
  Copyright (c) 2007-2019 Saleen Software       2019-03-20 03:43:09